Trouble connecting with PGAdmin4

I am trying to connect from PgAdmin

from this documentation, Connecting with older clients — Neon Docs
it seems like pgadmin should be able to connect and supports the SNI

but I haven’t been able to get it to work
I’ve gotten different errors:

  • timeout
  • connection refused on port 5432
  • could not translate hostname to address: nodename nor servname provided, or not known

i’ve tried the different recommendations on that connection issues page

  • adding the project option in the dbname as a key value
  • setting ssl to disable
  • setting ssl to verify full
  • passing the project in the password

but no luck.
any tips ?

I used PGAdmin4 version 6.11 on windows, and it worked:
I put my projects’ hostname “” in the host name/address box, default port, ‘main’ as the maintenance database, and the provided username/password from the console. Apart from that, I used the default configuration.

Note that PGAdmin4 version 6.10 and lower do not ship with a version of psql that supports, so you might have to update your version of PGAdmin4.

ah trying ‘main’ as the maintenance db was something i hadn’t tried

but still no luck, it times out trying to connect like that

this was all on PGAdmin 4 Version 6.15 (4280.88)

I used pgAdmin4 6.15 (0.62.2) on Windows. The following configuration works:

Register - Server in pgAdmin4

You can find the connection details on the Dashboard in the Neon Console, under Connection Details.

If you misplaced your password, you can reset it in the Neon Console, under Settings > Users.

Note that main is the default database created with each Neon project.

Oh! under connection details the domain was very different from what I grabbed from the connection string Hasura had (which is how I first got connected to Neon)
getting the correct connection details from the dashboard solved it, thank you very much @Daniel !

Glad it worked! Thanks for using Neon!